<!DOCTYPE html>

<!--[if lt IE 7 ]> <html class="ie ie6 no-js" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="ie ie7 no-js" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="ie ie8 no-js" lang="en-US"> <![endif]-->
<!--[if IE 9 ]>    <html class="ie ie9 no-js" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<!-- the "no-js" class is for Modernizr. -->

<head id="www-sitename-com" data-template-set="html5-reset-wordpress-theme" profile="http://gmpg.org/xfn/11">

	<meta charset="UTF-8">
	
	<!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	
	
	<title>
		     Gen-X in a Millennial World: A cause worth getting off the couch for - La Mesa Courier	</title>
	
	<meta name="title" content="  Gen-X in a Millennial World: A cause worth getting off the couch for - La Mesa Courier">
	<meta name="description" content="La Mesa Community News">
	
	<meta name="google-site-verification" content="">
	<!-- Speaking of Google, don't forget to set your site up: http://google.com/webmasters -->
	
	<meta name="Copyright" content="Copyright San Diego Downtown News 2012. All Rights Reserved.">
	
	<!--  Mobile Viewport meta tag
	j.mp/mobileviewport & davidbcalhoun.com/2010/viewport-metatag 
	device-width : Occupy full width of the screen in its current orientation
	initial-scale = 1.0 retains dimensions instead of zooming out if page height > device height
	maximum-scale = 1.0 retains dimensions instead of zooming in if page width < device width -->
	<!-- Uncomment to use; use thoughtfully!
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
	-->
	
	<link rel="shortcut icon" href="http://lamesacourier.com/wp-content/themes/lamesa/images/favicon.ico">
	<!-- This is the traditional favicon.
		 - size: 16x16 or 32x32
		 - transparency is OK
		 - see wikipedia for info on browser support: http://mky.be/favicon/ -->
		 
	<link rel="apple-touch-icon" href="http://lamesacourier.com/wp-content/themes/lamesa/_/img/apple-touch-icon.png">
	<!-- The is the icon for iOS's Web Clip.
		 - size: 57x57 for older iPhones, 72x72 for iPads, 114x114 for iPhone4's retina display (IMHO, just go ahead and use the biggest one)
		 - To prevent iOS from applying its styles to the icon name it thusly: apple-touch-icon-precomposed.png
		 - Transparency is not recommended (iOS will put a black BG behind the icon) -->
	
	<!-- CSS: screen, mobile & print are all in the same file -->
	<link rel="stylesheet" href="http://lamesacourier.com/wp-content/themes/lamesa/style.css">
	
	<!-- all our JS is at the bottom of the page, except for Modernizr. -->
	<script src="http://lamesacourier.com/wp-content/themes/lamesa/_/js/modernizr-1.7.min.js"></script>
    
	<script src="http://lamesacourier.com/wp-content/themes/lamesa/_/js/jquery.dropdownPlain.js"></script>

	<script src="http://lamesacourier.com/wp-content/themes/lamesa/_/js/hoverIntent.js"></script>

	
	<link rel="pingback" href="http://lamesacourier.com/xmlrpc.php" />

	
	
    
 <script type='text/javascript' src='http://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-3351708533649643");
GS_googleEnableAllServices();
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-3351708533649643", "sandiegodtn-sandiegodtncom406_WeatherPage_ATF_MainColumn_Window_590x287");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>   
	<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="La Mesa Courier &raquo; Feed" href="http://lamesacourier.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="La Mesa Courier &raquo; Comments Feed" href="http://lamesacourier.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="La Mesa Courier &raquo; Gen-X in a Millennial World: A cause worth getting off the couch for Comments Feed" href="http://lamesacourier.com/gen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for/feed/" />
<meta property="og:image" content="http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X-300x225.jpg"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/lamesacourier.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style type="text/css">
	
</style><link rel='stylesheet' id='wpsqt-main-css'  href='http://lamesacourier.com/wp-content/plugins/wp-survey-and-quiz-tool/css/main.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-wpmu-ui-3-min-css-css'  href='http://lamesacourier.com/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/css/wpmu-ui.3.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-3-min-css-css'  href='http://lamesacourier.com/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/css/animate.3.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='A2A_SHARE_SAVE-css'  href='http://lamesacourier.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.13' type='text/css' media='all' />
<link rel='stylesheet' id='socialwiggle-css'  href='http://lamesacourier.com/wp-content/plugins/social-wiggle/css/socialwiggle.css?ver=0.8.2' type='text/css' media='all' />
<script type='text/javascript' src='http://lamesacourier.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/wp-survey-and-quiz-tool/js/site.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/social-wiggle/js/socialwiggle.js?ver=0.8.2'></script>
<link rel='https://api.w.org/' href='http://lamesacourier.com/wp-json/' />
<link rel='prev' title='Vineyard and viticulture classes at Cuyamaca' href='http://lamesacourier.com/vineyard-and-viticulture-classes-at-cuyamaca/' />
<link rel='next' title='Rowing club receives recognition' href='http://lamesacourier.com/rowing-club-receives-recognition/' />
<link rel="canonical" href="http://lamesacourier.com/gen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for/" />
<link rel='shortlink' href='http://lamesacourier.com/?p=3786' />
<link rel="alternate" type="application/json+oembed" href="http://lamesacourier.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flamesacourier.com%2Fgen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://lamesacourier.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flamesacourier.com%2Fgen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for%2F&#038;format=xml" />

<script type="text/javascript">
var a2a_config=a2a_config||{};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.templates=a2a_config.templates||{};
a2a_config.templates = {
    twitter: "Reading: ${title} ${link} by @lamesacourier"
};
</script>
<script type="text/javascript" src="http://static.addtoany.com/menu/page.js" async="async"></script>

<!-- This site is using AdRotate v3.16.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { min-width:4px; max-width:258px; }
	.b-1 { margin:4px; }
	.g-2 { min-width:4px; max-width:258px; }
	.b-2 { margin:4px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

</head>

<body class="post-template-default single single-post postid-3786 single-format-standard">
        
<div id="top">
<div id="innerTop">
<div id="topNav"><div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-16" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-16"><a href="http://lamesacourier.com/">Home</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="http://lamesacourier.com/about-la-mesa-courier/">About</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19"><a href="http://lamesacourier.com/la-mesa-advertising/">Advertising</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20"><a href="http://lamesacourier.com/la-mesa-courier-digital-archives/">Digital Archives</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18"><a href="http://lamesacourier.com/contact-la-mesa-courier/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a href="http://lamesacourier.com/letter-to-editor/">Letter to Editor</a></li>
</ul>
</li>
<li id="menu-item-462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-462"><a href="http://lamesacourier.com/find-us/">Find us</a></li>
</ul></div> </div>
<div id="social">    <div id="text-2" class="socIcons widget_text">			<div class="textwidget"><!-- BEGIN: Constant Contact Stylish Email Newsletter Form -->
<div class="enews">
 <img src="http://sandiegodowntownnews.com/wp-content/themes/downtown/images/mailbox.jpg" width="34" height="35" alt="mail" /><span class="signup">Sign up for our eNewsletter</span><br />
<form name="ccoptin" action="http://visitor.r20.constantcontact.com/d.jsp" target="_blank" method="post" class="ccform">
  <input type="text" name="ea" size="20" value="">
  <input type="submit" name="go" value="GO" class="submit">
  <input type="hidden" name="llr" value="axr74beab">
  <input type="hidden" name="m" value="1103873591008">
  <input type="hidden" name="p" value="oi">
</form>
</div>
<!-- END: Constant Contact Stylish Email Newsletter Form --></div>
		</div><div id="socwig_widget-2" class="socIcons widget_socwig_widget"><!-- Powered by SocialWiggle : http://fooplugins.com/products/socialwiggle-pro/ -->
<div class="socwig-container socwig-32 socwig-rounded socwig-wiggle-on-hover"><a href="http://www.twitter.com/lamesacourier" target="_blank" rel="nofollow" class="socwigbtn socwig-twitter" title="Follow On Twitter"></a><a href="http://www.facebook.com/lamesacourier" target="_blank" rel="nofollow" class="socwigbtn socwig-facebook" title="Like On Facebook"></a></div><div class="social-wiggle-powered">Powered by <a target="_blank" title="SocialWiggle Free WordPress Plugin" href="http://fooplugins.com/plugins/socialwiggle-lite/">SocialWiggle</a></div></div> </div>
<!--innerTop--></div>
<!--top--></div>

<div id="wrap">

<header>
	<div id="logo">
  		<h1><a href="http://lamesacourier.com/">La Mesa Courier        La Mesa Community News</a></h1>
   </div>
	
   <div id="papers">
  		<ul>
        	<li><a href="http://gay-sd.com/" target="_blank">Gay San Diego</a></li>
  			<li><a href="http://sduptownnews.com/" target="_blank">San Diego Uptown News</a></li>
            <li><a href="http://sandiegodowntownnews.com/" target="_blank">San Diego Downtown News</a></li>
  			
  		</ul>
        
        <ul>
        	<li><a href="http://lamesacourier.com/" target="_blank">La Mesa Courier</a></li>
            <li><a href="http://missionvalleynews.com/" target="_blank">Mission Valley News</a></li>
  			<li><a href="http://missiontimescourier.com/" target="_blank">Mission Times_Courier</a></li>  			
  		</ul>
	</div>
</header>

<nav><div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-72" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-72"><a href="http://lamesacourier.com/category/arts-entertainment/">Arts &#038; Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-126"><a href="http://lamesacourier.com/category/arts-entertainment/la-mesa-reads/">La Mesa Reads</a></li>
	<li id="menu-item-73" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73"><a href="http://lamesacourier.com/category/arts-entertainment/music/">Music</a></li>
	<li id="menu-item-74" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74"><a href="http://lamesacourier.com/category/arts-entertainment/theater/">Theater</a></li>
</ul>
</li>
<li id="menu-item-127" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-127"><a href="http://lamesacourier.com/category/calendar/">Calendar</a>
<ul class="sub-menu">
	<li id="menu-item-2290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2290"><a href="http://lamesacourier.com/category/calendar/arts-calendar/">Arts Calendar</a></li>
</ul>
</li>
<li id="menu-item-75" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-75"><a href="http://lamesacourier.com/category/columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-709"><a href="http://lamesacourier.com/category/columns/diannes-corner/">Dianne’s Corner</a></li>
	<li id="menu-item-1456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1456"><a href="http://lamesacourier.com/expert-advice/">Expert Advice</a></li>
	<li id="menu-item-401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-401"><a href="http://lamesacourier.com/category/columns/foothiller-footsteps/">Foothiller Footsteps</a></li>
	<li id="menu-item-76" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-76"><a href="http://lamesacourier.com/category/columns/gen-x-in-la-mesa/">Gen-X in a Millennial World</a></li>
	<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="http://lamesacourier.com/category/columns/helix-highlights/">Helix Highlights</a></li>
	<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="http://lamesacourier.com/category/columns/la-mesa-foothills-democratic-club/">La Mesa Foothills Democratic Club</a></li>
	<li id="menu-item-128" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-128"><a href="http://lamesacourier.com/category/columns/navajo-canyon-republican-women/">Navajo Canyon Republican Women</a></li>
	<li id="menu-item-129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129"><a href="http://lamesacourier.com/category/columns/the-sun-shines-sooner/">The Sun Shines Sooner…</a></li>
</ul>
</li>
<li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-83"><a href="http://lamesacourier.com/category/food-drink/">Food &#038; Drink</a>
<ul class="sub-menu">
	<li id="menu-item-130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-130"><a href="http://lamesacourier.com/category/food-drink/recipes/">Recipes</a>
	<ul class="sub-menu">
		<li id="menu-item-131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131"><a href="http://lamesacourier.com/category/food-drink/recipes/whats-cooking-with-julie/">What&#8217;s cooking with Julie</a></li>
	</ul>
</li>
	<li id="menu-item-132" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-132"><a href="http://lamesacourier.com/category/food-drink/restaurant-reviews/">Restaurant Reviews</a></li>
</ul>
</li>
<li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-84"><a href="http://lamesacourier.com/category/lifestyle/">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-710"><a href="http://lamesacourier.com/category/lifestyle/home-garden/">Home &#038; Garden</a></li>
	<li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="http://lamesacourier.com/category/lifestyle/pets/">Pets</a></li>
</ul>
</li>
<li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-86"><a href="http://lamesacourier.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-300"><a href="http://lamesacourier.com/category/news/business/">Business</a></li>
	<li id="menu-item-301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-301"><a href="http://lamesacourier.com/category/news/features/">Features</a></li>
	<li id="menu-item-133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-133"><a href="http://lamesacourier.com/category/news/from-the-cover/">From the cover</a></li>
	<li id="menu-item-299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-299"><a href="http://lamesacourier.com/category/news/la-mesa-news-briefs-news/">La Mesa News Briefs</a></li>
	<li id="menu-item-870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-870"><a href="http://lamesacourier.com/category/news/noteworthy/">Noteworthy</a></li>
</ul>
</li>
<li id="menu-item-712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-712"><a href="http://lamesacourier.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-302"><a href="http://lamesacourier.com/category/opinion/guest-editorial/">Guest Editorial</a></li>
	<li id="menu-item-851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-851"><a href="http://lamesacourier.com/category/opinion/letters-to-the-editor/">Letters to the editor</a></li>
</ul>
</li>
</ul></div> </nav>

<div id="innerWrap">
<section>
	
		<article class="post-3786 post type-post status-publish format-standard has-post-thumbnail hentry category-columns category-featured category-gen-x-in-la-mesa" id="post-3786">
			
			<h1 class="entry-title">Gen-X in a Millennial World: A cause worth getting off the couch for</h1>
            <div class="meta">
	Posted: January 27th, 2017 | <a href="http://lamesacourier.com/category/columns/" rel="category tag">Columns</a>, <a href="http://lamesacourier.com/category/featured/" rel="category tag">Featured</a>, <a href="http://lamesacourier.com/category/columns/gen-x-in-la-mesa/" rel="category tag">Gen-X in a Millennial World</a> | <a href="http://lamesacourier.com/gen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for/#respond" class="comments-link" >No Comments</a></div>
			<div class="entry">
				
				<p>By Genevieve A. Suzuki | Gen-X in a Millennial World</p>
<p>If you had told me two years ago I would have been on a flight to Washington D.C. on Jan. 19, 2017 to participate in a civil rights march, I would have thought you had the wrong person.</p>
<p>I am the stereotypical Generation X’er. I generally prefer to watch things develop from the comfort of my couch.<span id="more-3786"></span></p>
<p>And although I am an attorney who is active in community organizations, I have become rather complacent. None of my involvements required true activism: I sit on the board for La Mesa Park and Recreation Foundation and serve as a commissioner for the City of La Mesa’s Community Services Commission.</p>
<p>I am also a member of the Japanese American Citizens League, but have participated in activities that were more cultural than contentious. Parks and cultural awareness do not exactly inspire ire.</p>
<p>On Nov. 8, 2016, however, I was shocked into action after my country elected a president who demeaned women in his speech. A president whose campaign aimed to divide rather than unite.</p>
<p>I’m not going to lie. I was shattered. As a woman who was raised to believe we were equal to men and that we deserved our fair share of respect, the fact a candidate could get elected after saying such awful things blew my mind. Worse, my daughter just witnessed an election in favor of a man who dismissed his inappropriate words as “locker room talk.”</p>
<p>It wasn’t okay.</p>
<p>So when I saw a brief blurb about marching in Washington D.C. the day after the inauguration I immediately discussed it with my husband. Could he handle our 18-month-old son for a few days? Would it be all right for me to leave for three nights so I could march against that mistreatment of women?</p>
<p>My husband, who, like me, has never been vocal about controversial issues, made me proud: “You have to go, Gen. Go for us.”</p>
<p>That’s how I found myself on the way to what would be my first march for civil rights. And boy, was it a doozy.</p>
<div id="attachment_3787" style="width: 610px" class="wp-caption aligncenter"><a href="http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X.jpg"><img class="size-full wp-image-3787" src="http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X.jpg" alt="" width="600" height="450" srcset="http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X.jpg 600w, http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X-300x225.jpg 300w, http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X-256x192.jpg 256w, http://lamesacourier.com/wp-content/uploads/2017/01/Gen-X-134x100.jpg 134w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Genevieve Suzuki (far left) with fellow marchers she met at the airport. (Courtesy Genevieve Suzuki)</p></div>
<p>It started on my flight to Washington. I met fellow San Diegan Ellen Montanari during my layover in Chicago. We sat and talked about how we couldn’t miss this march.</p>
<p>“I had to go to D.C.,” she said. “I had to be there.”</p>
<p>Ellen, who wore a Women’s March shirt beneath her coat, also shared with me websites and ways I could continue to be involved.</p>
<p>After getting off the plane, we took photos with fellow passengers who were also headed to the march. Another marcher happily gave me a pink hat, knitted by a friend who had to do something — anything — even if it was to knit several hats for other participants.</p>
<p>March organizers initially expected around 250,000 of us, but they got more than half a million. Getting on the Metro that morning, I was nervous. I had been warned off by a few friends and family, who were concerned for my safety.</p>
<p>They needn’t have worried. This march was a salve for my soul. There were so many of us we broke the march. But as we were turned away from the planned route, we began marching down adjacent streets.</p>
<p>Fittingly, we marched up Constitution Avenue, chanting, “This is what democracy looks like!” as we passed the Newseum, which features the First Amendment on its facade, reminding us of our rights to free speech and peaceably assemble.</p>
<p>Perhaps the most interesting quality about this march was the warmth, support and encouragement among the marchers. When parents tried to navigate through the crowd with their young children, people would call out, “stroller,” and we would all create a pathway.</p>
<p>We admired each other’s signs and exchanged personal information so we could stay in contact. We were activated; awakened to a new political climate that demands vigilance and personal involvement.</p>
<p>Now I find myself on a new path, ready to take stands and make my voice heard. For that, I am actually grateful to President Donald J. Trump. In this way, he has unified us against an administration who would rather lie about inaugural attendance than respond to reporters’ questions.</p>
<p>And while it was easier to watch from the sidelines, it’s time to get off the couch so our children know that dignity, esteem and compassion belong to us all, regardless of our gender and backgrounds.</p>
<p><em>—Genevieve A. Suzuki is a La Mesa resident who practices family law. Visit her website at <a href="http://www.sdlawyersuzuki.com/" target="_blank">sdlawyersuzuki.com</a>.</em></p>

								
				                
                <div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://lamesacourier.com/gen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for/" data-a2a-title="Gen-X in a Millennial World: A cause worth getting off the couch for"><a class="a2a_button_facebook" href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Flamesacourier.com%2Fgen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for%2F&amp;linkname=Gen-X%20in%20a%20Millennial%20World%3A%20A%20cause%20worth%20getting%20off%20the%20couch%20for" title="Facebook" rel="nofollow" target="_blank"></a><a class="a2a_button_twitter" href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Flamesacourier.com%2Fgen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for%2F&amp;linkname=Gen-X%20in%20a%20Millennial%20World%3A%20A%20cause%20worth%20getting%20off%20the%20couch%20for" title="Twitter" rel="nofollow" target="_blank"></a><a class="a2a_button_google_plus" href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Flamesacourier.com%2Fgen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for%2F&amp;linkname=Gen-X%20in%20a%20Millennial%20World%3A%20A%20cause%20worth%20getting%20off%20the%20couch%20for" title="Google+" rel="nofollow" target="_blank"></a><a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share"></a></div> 
		

			</div>
			
			
		</article>

	

			<!-- If comments are open, but there are no comments. -->

	 	


<div id="respond">

	<h2>Leave a Comment</h2>

	<div class="cancel-comment-reply">
		<a rel="nofollow" id="cancel-comment-reply-link" href="/gen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for/#respond" style="display:none;">Click here to cancel reply.</a>	</div>

	
	<form action="http://lamesacourier.com/wp-comments-post.php" method="post" id="commentform">

		
			<div>
				<input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
				<label for="author">Name (required)</label>
			</div>

			<div>
				<input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' />
				<label for="email">e-mail (will not be published) (required)</label>
			</div>

			<div>
				<input type="text" name="url" id="url" value="" size="22" tabindex="3" />
				<label for="url">Website</label>
			</div>

		
		<!--<p>You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></p>-->

		<div>
			<textarea name="comment" id="comment" cols="58" rows="10" tabindex="4"></textarea>
		</div>

		<div>
			<input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
			<input type='hidden' name='comment_post_ID' value='3786' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
		</div>
		
		<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="73fae26a77" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="86"/></p>
	</form>

		
</div>


	 
 </section>    
	
<aside>

   <div id="text-3" class="widget widget_text">			<div class="textwidget"><a href="http://lamesacourier.com/traffic-report/"><img class="traffic" title="san-diego-traffic" src="http://www.gay-sd.com/wp-content/uploads/2012/04/san-diego-traffic.png" alt="" width="135" height="55" /></a>

<a href="http://lamesacourier.com/san-diego-weather/"><img class="weather" title="san-diego-weather" src="http://sandiegodowntownnews.com/wp-content/uploads/2012/05/san-diego-weather.png" alt="" width="135" height="55" /></a>
</div>
		</div><div id="search-3" class="widget widget_search"><form action="http://lamesacourier.com" id="searchform" method="get">
    <div>
        <input type="search" id="s" name="s" value="" />
        
        <input type="submit" value="Search" id="searchsubmit" />
    </div>
</form></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><div class="digital">

View the current <a href="https://issuu.com/awodigitaledition/docs/la_mesa_courier_01-27-17?e=2076238/43592633" target="_blank">Digital Edition</a> of La Mesa Courier

<a href="https://issuu.com/awodigitaledition/docs/la_mesa_courier_01-27-17?e=2076238/43592633" target="_blank"><img title="LMC-Digital" src="http://lamesacourier.com/wp-content/uploads/2017/01/webSmallLMC.jpg" /></a>

</div>
</div>
		</div><div id="text-5" class="widget widget_text">			<div class="textwidget"><div class="digital">

<a href="
https://issuu.com/awodigitaledition/docs/la_mesa_courier_04-22-16/11?e=2076238/35095333" target="_blank">2015 Best of La Mesa</a>

<a href="
https://issuu.com/awodigitaledition/docs/la_mesa_courier_04-22-16/11?e=2076238/35095333" target="_blank"><img title="Uptown-Digital" src="http://lamesacourier.com/wp-content/uploads/2016/07/WebSmallLMC-1.jpg" /></a></div>
		</div><div id="text-6" class="widget widget_text">			<div class="textwidget"><div class="digital">

Vote here for the <a href="https://www.cognitoforms.com/SDCNN/BestOfLaMesa2016" target="_blank">2016 Best of La Mesa</a></div>
		</div>
    <div id="adrotate_widgets-12" class="widgetAds adrotate_widgets"><div class="g g-1"><div class="g-col b-1 a-45"><a class="gofollow" data-track="NDUsMSwxLDI0MA==" href="http://visitor.r20.constantcontact.com/d.jsp?llr=axr74beab&p=oi&m=1103873591008&sit=qh5kvmqfb&f=02141622-39f7-4c19-bf7b-2d2d13acced2" target="_blank"><img src="http://lamesacourier.com/wp-content/uploads/2015/12/web_banner_eblasts_lmc_1215.jpg" /></a></div></div></div><div id="adrotate_widgets-8" class="widgetAds adrotate_widgets"><div class="g g-2"><div class="g-col b-2 a-68"><a class="gofollow" data-track="NjgsMiwxLDI0MA==" href="http://www.sandiegoduilawyersblog.com" target="_blank"><img src="http://lamesacourier.com/wp-content/uploads/2016/11/Susan-Hartman_031116_250х250_sdcnn_OY-01.jpg" /></a></div></div><div class="g g-2"><div class="g-col b-2 a-73"><a class="gofollow" data-track="NzMsMiwxLDI0MA==" href="http://www.circusvargas.com" target="_blank"><img src="http://lamesacourier.com/wp-content/uploads/2017/01/SD-GEN-27_250x250_Towns.jpeg" /></a></div></div><div class="g g-2"><div class="g-col b-2 a-72"><a class="gofollow" data-track="NzIsMiwxLDI0MA==" href="https://oss.ticketmaster.com/aps/sdsu/EN/buy/browse" target="_blank"><img src="http://lamesacourier.com/wp-content/uploads/2017/01/SDSUAztecFootball-250x250.jpeg" /></a></div></div></div>
</aside>
<!--innerWrap--></div>
<!--wrap--></div>

<footer>
	<div id="innerFooter"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="http://lamesacourier.com/">Home</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="http://lamesacourier.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24"><a href="http://lamesacourier.com/contact-la-mesa-courier/">Contact</a></li>
</ul></div> 
  	<p>Copyright &#169; 2017 La Mesa Courier. All rights reserved. &#8226; La Mesa Courier is part of sdCNN.</p>
  </div>
</footer>


	<script>window._popup_data = {"ajaxurl":"http:\/\/lamesacourier.com\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/gen-x-in-a-millennial-world-a-cause-worth-getting-off-the-couch-for\/"}};</script><script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/adrotate/library/jquery.adrotate.responsive.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/lamesacourier.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/js/wpmu-ui.3.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-content/plugins/wordpress-popup/js/public.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://lamesacourier.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
   


<!-- here comes the javascript -->

<!-- jQuery is called via the Wordpress-friendly way via functions.php -->

<!-- this is where we put our custom functions -->
<script src="http://lamesacourier.com/wp-content/themes/lamesa/_/js/functions.js"></script>
	 
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56681642-1', 'auto');
  ga('send', 'pageview');

</script>

	
</body>

</html>
